Difference between revisions of "User:AndrewW/Gentoo"

From FreeOrionWiki
Jump to: navigation, search
m (Gentoo [64-bit])
(Old and stale, we don't use SourceForce or Ogre)
 
Line 1: Line 1:
===Gentoo [64-bit]===
 
  
You will need the following packages:
 
 
* ogre
 
* boost (needs the python use flag)
 
* bullet
 
* openal
 
* freealut
 
* libogg
 
* libvorbis
 
* zlib
 
* libpng
 
* ois
 
* subversion
 
 
Some of these may already be installed and you may not need to emerge all of these:
 
 
emerge ogre boost bullet openal freealut libogg libvorbis zlib libpng ois subversion -a
 
 
To set python to a 2.x version:
 
 
eselect python list
 
eselect python set x (replace with the number from the above list)
 
 
Get the current build:
 
 
svn co http://svn.code.sf.net/p/freeorion/code/trunk/FreeOrion/ freeorion
 
 
Compile: (You should already be in the freeorion directory at this point, if not switch to that first)
 
 
cmake .
 
make
 
 
To run:
 
 
./freeorion
 
 
Enjoy.
 
 
No guarantees, but it worked for me anyways thought it might help someone else out.
 

Latest revision as of 18:09, 15 March 2018