Difference between revisions of "System Requirements"

From FreeOrionWiki
Jump to: navigation, search
m (Reverted edit of 203.199.144.208, changed back to last version by Geoff the Medio)
Line 1: Line 1:
Unfortunately, the project had to be closed down, as the admins behaved in a most unprofessional manner, causing FreeOrion to be a total failure. We are sorry.
+
[[FreeOrion]] does not yet have official system requirements, and what it currently needs is highly likely to fluctuate throughout the development.
 +
 
 +
As a rough guideline, FreeOrion is reported to ''run'' on a 600MHz machine with 128MB internal memory, however this did not constitute for a good playing experience; you will want to have more.  Additionally, FO uses [[OpenGL]], meaning you should have a 3D accelerator card.  A screen resolution of 1024x768 or larger is very strongly reccomended, though the game can be run, awkwardly, at lower resolutions.
 +
 
 +
If you have experience running it on a particular system and thought it was a bit slow, please write your requirements here so we can consolidate them into some guideline of reasonable specifications.
 +
 
 +
You will need as an operating system either Linux or Windows XP Service Pack 2.  Earlier versions of Windows will not work, including WinME, Win 2000, or Win98, or earlier versions of Windows XP including SP1 and SP2-beta.
 +
 
 +
Ports to other systems are plausible but require developers from them to put in the time to see it ported.

Revision as of 19:35, 29 July 2006

FreeOrion does not yet have official system requirements, and what it currently needs is highly likely to fluctuate throughout the development.

As a rough guideline, FreeOrion is reported to run on a 600MHz machine with 128MB internal memory, however this did not constitute for a good playing experience; you will want to have more. Additionally, FO uses OpenGL, meaning you should have a 3D accelerator card. A screen resolution of 1024x768 or larger is very strongly reccomended, though the game can be run, awkwardly, at lower resolutions.

If you have experience running it on a particular system and thought it was a bit slow, please write your requirements here so we can consolidate them into some guideline of reasonable specifications.

You will need as an operating system either Linux or Windows XP Service Pack 2. Earlier versions of Windows will not work, including WinME, Win 2000, or Win98, or earlier versions of Windows XP including SP1 and SP2-beta.

Ports to other systems are plausible but require developers from them to put in the time to see it ported.