Talk:Compile In Linux

From FreeOrionWiki
Jump to: navigation, search

Another reason for segfaults:

Old hardware doesn't like the rendering of nebulae. Disable in the options.

This segfault appears after you set up you're game and before you can see the star map for the first time...

I suggest to mention this with the other possible reason for a segfault. --V 12:48, 20 August 2008 (EDT) Running FreeOrion on unsupported hardware is not problem for FreeOrion. Current version may run, nut later it will be also another things which will require modern hardware(something like FreeOrion tech demo).

Bullet Configuration Problem:

The instructions list the "apt-get" command for libglut and then in the next line talk about unpacking and compiling the archive. This is confusing. If you installed it through apt-get does it still need to be compiled? If so where does the archive reside?

August 9, 2009

You download prerequisites for bullet via apt-get and then download bullet. Archive is where you download it from bullet homepage.

Ogre 1.6.3 in Debian repositories

Ogre3D in Debian Sid repository has been updated to version 1.6.3. What was the problem with old Debian provided Ogre packet, and is it still true with new packet? Or can we now instruct people to use Debian provided Ogre instead of compiling it. --cazfi 10:46, 29 September 2009 (EDT)

Ogre3D was built without nvidia-cg-toolkit in repository. Cg-toolkit is required to run FreeOrion tech-demo. Now there is package ogre-plugins-cgprogrammanager which solves this problem(only in version 1.6.1). Version 1.6.3 is not available, therefore Ogre3D in Debian unstable is broken. Linux compile howto shall be rewritten to use official repository Ogre3D. According this bug problem is also in Ubuntu. Problem is that in some time Ogre3D in version 1.6.3 goes to testing. Therefore howto rewrites could wait.
Ogre3D in Debian testing is in version 1.6.4, therefore compilation Ogre3D for Debian is not needed anymore.

Minimum boost version

Discussion in seems to indicate that minimum boost version is now 1.42. I've got error mentioned in the thread with boost 1.40, with which Ubuntu Lucid Lynx comes. --cazfi 12:17, 26 May 2010 (EDT)

GiGi is missing the file INSTALL

Hint for GiGi "make install": in case you get the error "file INSTALL cannot find", then touch it, like

md doc/GG

touch doc/GG/INSTALL

and try to do it again (still seen with rev 3955) Maybe someone could add this into the make file for the time beeing