Page 1 of 1

Game crash after changing directories

Posted: Sun Apr 14, 2024 4:48 pm
by drkosy
To test my kosymod, I went to the options -> directories and changed Resource Files to my kosymod directory. After I klicked "Done" the game crashes immediately. The logs doesn't show any hint what went wrong. The last entry in freeorion log is just "Lost Focus".

Tested with recent build from today (2024-04-14).

Is there any way to change the resource files directory by commandline?

Re: Game crash after changing directories

Posted: Sun Apr 14, 2024 5:45 pm
by Geoff the Medio
freeorion --resource.path

I just switched the resource path in the GUI without problem.

Maybe something's missing in the modded directory that it doesn't do safety checks for?

Re: Game crash after changing directories

Posted: Sun Apr 14, 2024 9:12 pm
by drkosy
For testing purposes I just copied the "default" folder in the github clone, put it into the directory of the game (renamed to kosymod) and switched path through the GUI. The game crashed. Don't think something is missing because it contains the same files as the link to the default folder.

I tried the commandline (./freeorion --resource.path kosymod/) the game crashed but I got

Code: Select all

terminate called after throwing an instance of 'boost::filesystem::filesystem_error'
  what():  boost::filesystem::directory_iterator::construct: No such file or directory [system:2]: "kosymod/kosymod/scripting/buildings"
The problem seems to be that he should take just "kosymod/scripting" instead of "kosymod/kosymod/scripting"

Now I just created a directory "kosymod/kosymod" and put all my files there. The game started but I got:

Code: Select all

[2024-04-14 23:01:05.916574] [0x00007f08e4ea7c00] [info]    Resources directory from config.xml missing or does not contain expected files. Resetting to default.
[2024-04-14 23:01:05.916591] [0x00007f08e4ea7c00] [info]    Refreshed ResDir
No content changed in the game. But I wonder, because config.xml is placed at ~/.config/freeorion and nor the path or the file itself should change.

Maybe my testing could provide you some information to find what's wrong.

BTW: I use fedora linux 39 with KDE Plasma and a new build FO, version 2024-04-14 master branch