Compiling under Linux - CMake - Python error

Questions, problems and discussion about compiling FreeOrion.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
User avatar
andrewthehammer87
Krill Swarm
Posts: 12
Joined: Wed Aug 05, 2015 2:35 pm
Location: Hungary/UK

Compiling under Linux - CMake - Python error

#1 Post by andrewthehammer87 » Fri Mar 20, 2020 6:06 pm

Hey guys!

I am trying to compile from source on MXLinux 18.3(I don't think the version is relevant, but why not) and I have followed the Compilation Guide until I started to CMake for the first time and the following error occured(see picture below):

I have installed everything that the Synaptic Installer possibly could install, but what do I need to do now, since the last time I checked, the version of the python installation was at least 2.7.
Screenshot_freeorion_cmake_firstrun.png
Screenshot_freeorion_cmake_firstrun.png (162.54 KiB) Viewed 153 times
Please help, if you can.
Thanks a bunch.
All my work released for FreeOrion is licensed under CC BY-SA 3.0

o01eg
Programmer
Posts: 735
Joined: Sat Dec 10, 2011 5:46 am

Re: Compiling under Linux - CMake - Python error

#2 Post by o01eg » Fri Mar 20, 2020 8:00 pm

I suppose you need to install devel packages for python and other libraries.
Gentoo Linux x64, gcc-9.2, boost-1.72.0
Ubuntu Server 18.04 x64, gcc-7.4, boost-1.65.1
Welcome to the slow multiplayer game at freeorion-lt.dedyn.io. Version 2020-03-30.025f545.
Donations are welcome: BTC:14XLekD9ifwqLtZX4iteepvbLQNYVG87zK

User avatar
andrewthehammer87
Krill Swarm
Posts: 12
Joined: Wed Aug 05, 2015 2:35 pm
Location: Hungary/UK

Re: Compiling under Linux - CMake - Python error

#3 Post by andrewthehammer87 » Fri Mar 20, 2020 8:08 pm

All right, I will try that.

But first, I just realised I forgot to attach the most important thing, the log files.

CMakeError.log
(2.88 KiB) Downloaded 4 times
CMakeOutput.log
(46.69 KiB) Downloaded 1 time
All my work released for FreeOrion is licensed under CC BY-SA 3.0

Ophiuchus
Programmer
Posts: 1267
Joined: Tue Sep 30, 2014 10:01 am
Location: Wall IV

Re: Compiling under Linux - CMake - Python error

#4 Post by Ophiuchus » Tue Mar 24, 2020 5:14 pm

If you are trying to compile the latest master you will need python3 - we are in the process of removing python2.
Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

Furthermore, I propse... we should default to four combat rounds instead of three ...for the good of playerkind.

Post Reply