Can't run the game off installation

For topics that do not fit in another sub-forum.

Moderator: Oberlus

Locked
Message
Author
Lord_Edwin
Space Krill
Posts: 1
Joined: Wed Jul 12, 2006 10:41 pm

Can't run the game off installation

#1 Post by Lord_Edwin »

I've downloaded the 1.3.1-RC4 Setup file from SourceForge and once it's done installing, it can't run the game. The error message I recieve says it's because the "application configuration is incorrect". Reinstalling has not changed anything, nor has re-downloading the same or older versions of the game.

Am I missing something?

Thanks!
Greg

User avatar
pd
Graphics Lead Emeritus
Posts: 1924
Joined: Mon Mar 08, 2004 6:17 pm
Location: 52°16'N 10°31'E

#2 Post by pd »

Do you have the .NET framewore installed?
wiki wrote:Note that this binary requires .NET Framework 2.0, which you can get by running Windows Update, selecting "Custom", then "Optional, Software", then ".NET Framework 2.0", or download it directly from Microsoft.

Jake Badlands
Space Krill
Posts: 3
Joined: Sun Aug 27, 2006 5:27 pm

#3 Post by Jake Badlands »

I have the same problem, and I have .Net installed and fully updated on WinXP Pro SP2.

Any suggestions? I've never played, but I can't wait to try it. I'm a huge MoO2 fan, and I need a MoO fix after MoO3's climactic letdown. :)

marhawkman
Large Juggernaut
Posts: 938
Joined: Fri Jan 20, 2006 9:34 pm
Location: GA

#4 Post by marhawkman »

You guys sure you've got 2.0?
Computer programming is fun.

SilverStraw
Space Krill
Posts: 1
Joined: Wed Jun 14, 2006 9:41 pm

#5 Post by SilverStraw »

I installed both versions of .net and I still can't get past the error message.
I'm running winxp i think sp2. I also have problems getting Windows media player to work.
G.K. Chesterston :"before you pull down any fence, try and find out why it was put up in the first place."

Jake Badlands
Space Krill
Posts: 3
Joined: Sun Aug 27, 2006 5:27 pm

.Net 2.0

#6 Post by Jake Badlands »

Apparently I had .Net 1.1, even though Windows Update said it was up to date. So I installed .Net 2.0, and it solved that problem. I'll post the new problem in a new thread.

User avatar
NuttyMonk
Space Floater
Posts: 15
Joined: Mon Mar 24, 2008 9:26 am
Location: Edinburgh, Scotland

Re: Can't run the game off installation

#7 Post by NuttyMonk »

I have XP SP2 (i just checked) and i also re-installed .NET framework 2 (although i already had it) but i get the same message that has been noted here about the configuration being incorrect.

I had installed the latest version of free orion 0.3.8, but i'm gonna try uninstalling it and re-installing it again. If that still doesn't work can anyone suggest a way to fix this? I also checked that the python .dll file is in the free orion folder.

Cheers

Monk

p.s. what does this file do --> vcredist_x86.exe
do i need to go through the microsoft visual C++ setup as well or is that just for developers?

m_k
Space Floater
Posts: 33
Joined: Wed Mar 12, 2008 10:54 am
Location: Aachen, Germany

Re: Can't run the game off installation

#8 Post by m_k »

The vcredist_x86.exe installs some files needed by programs compiled with visual c++, so you could try, but in theory if those were the missing files you would probably get an error mentioning a missing dll.
I believe somewhere around here a read about a case where the game didn't run using .net 2.0 but it worked using .net 3.5, so you could try that as well.

User avatar
pd
Graphics Lead Emeritus
Posts: 1924
Joined: Mon Mar 08, 2004 6:17 pm
Location: 52°16'N 10°31'E

Re: Can't run the game off installation

#9 Post by pd »

NuttyMonk wrote:I had installed the latest version of free orion 0.3.8, but i'm gonna try uninstalling it and re-installing it again. If that still doesn't work can anyone suggest a way to fix this? I also checked that the python .dll file is in the free orion folder.
Try installing 0.3 RC6 first and then 0.3.8. on top of it.
do i need to go through the microsoft visual C++ setup as well or is that just for developers?
You don't.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12799
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Can't run the game off installation

#10 Post by Geoff the Medio »

Please check for more recent threads (ie. within a year and a half and specific to the current version) for issues such as this. The same error message keeps popping up over the years, but the exact cause changes depending on what weird problems there are with Visual Studio.

For v0.3.8 install issues:
viewtopic.php?f=2&t=2106

Locked