Page 2 of 2

Re: planets troops increasing even with attacking ships in o

Posted: Sat Feb 17, 2018 10:46 am
by Geoff the Medio
Oberlus wrote:The compiled version, pulled from github two days ago, has the same problem.
Update to the latest.

Re: planets troops increasing even with attacking ships in o

Posted: Sat Feb 17, 2018 10:58 am
by Oberlus
OK, thank you, I'll do it ASAP (probably this evening) and report.

Re: planets troops increasing even with attacking ships in o

Posted: Sat Feb 17, 2018 4:36 pm
by Oberlus
The invasion button appears, and it works. But it seems something is still broken for the AI, it wont invade any planet, despite having visibility, defenses down, armed ships and more than enough troops for the invasion in orbit of the planet for several (5+) turns.

Re: planets troops increasing even with attacking ships in o

Posted: Sun Feb 18, 2018 12:13 am
by Dilvish
Oberlus wrote:The invasion button appears, and it works. But it seems something is still broken for the AI, it wont invade any planet, despite having visibility, defenses down, armed ships and more than enough troops for the invasion in orbit of the planet for several (5+) turns.
Yes, the AI hasn't yet gotten these updates from CurrentMeter to InitialMeter that the human UI just got. I'll be trying to get a PR together for that later tonight, hopefully in time for a little review and testing and then hopefully getting merged before next week's build.

Re: planets troops increasing even with attacking ships in o

Posted: Sun Feb 18, 2018 5:44 pm
by Dilvish
The fix for AI invasions of generally-shielded planets was a simple fix, I did a quick test and pushed it to master rather than holding it up with a PR.

I'll also do a review of other AI uses of CurrentMeter and decide which ones would probably be better as InitialMeter, depending on how clear the decision seems I may push it directly or put up a PR.

Side note, I also put in a fix for SP_SLY-- they had been suicidally dejected over their recent affliction with BAD_SUPPLY and were essentially not colonizing at all, that's fixed now.

Re: planets troops increasing even with attacking ships in o

Posted: Tue Feb 20, 2018 8:23 pm
by Dilvish
dbenage-cx wrote:Given a system with only a single planet with Ancient Guardians, still seeing +1 troop gain where ships have attacked for 5+ turns.
This issue is still ongoing, I'm going to make a github Issue on it. One AI planet I was camped on was still getting troop regen of 5 per turn even though it was under constant attack by my ships, and a similar thing happened when one of my planets was under blockade from an AI.

Re: planets troops increasing even with attacking ships in o

Posted: Thu Feb 22, 2018 9:10 am
by Dilvish
This troop regen glitch is proving tough to corral. In the meantime, the AI has probably been under-performing and making testing less enjoyable, so I've put up a PR that includes both one 'normal' invasion planning improvement for the AI, plus a temporary adjustment basically informing the AI of this regen glitch. I suggest any active testers cherrypick both commits for now.

Re: planets troops increasing even with attacking ships in o

Posted: Sun Jan 13, 2019 2:49 pm
by Oberlus
I found a case in which troops of planets under siege are still increasing. I think the key might be here:
Geoff the Medio wrote:
Sun Feb 11, 2018 10:09 pm
Should meter regen be gated by when a battle occurred in the system, or by when the planet was attacked? Currently it's the latter, possibly with some lingering buggy - 1's in the scripts.
If the colony under siege has no defenses because they were wiped out in turn T-1 and the owner Empire has no defense regeneration techs, then on turn T+0 the colony won't be attacked and so its troops will increase. Does this make sense?

I certainly would expect my ships to keep shooting at the colony to keep troops at bay while more of my troopers are incoming.