Xenological Hybridization v4747

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
unjashfan
Creative Contributor
Posts: 175
Joined: Fri Dec 30, 2011 8:08 am

Xenological Hybridization v4747

#1 Post by unjashfan » Tue Mar 27, 2012 6:06 pm

Once this tech is active, adequate planets have a higher target population than good planets of the same size (medium gets +12 and small gets +8, haven't seen large or huge yet). I'm assuming this is likely a typo somewhere in FO's code, but if anyone wants screenshots or saves, I'll upload.

User avatar
eleazar
Design & Graphics Lead Emeritus
Posts: 3858
Joined: Sat Sep 23, 2006 7:09 pm
Location: USA — midwest

Re: Xenological Hybridization v4747

#2 Post by eleazar » Tue Mar 27, 2012 6:30 pm

I think you did not update all content file to 4747.
Those are old numbers and should be completely different after r4743.

unjashfan
Creative Contributor
Posts: 175
Joined: Fri Dec 30, 2011 8:08 am

Re: Xenological Hybridization v4747

#3 Post by unjashfan » Wed Mar 28, 2012 12:09 pm

Oops - I think I got Xen Genetics and Xen Hybridization mixed up. Anyway, here's a screenshot of the problem and the save file.
test.zip
(30.92 KiB) Downloaded 21 times
EDIT: Screenshot won't link as I would like to. Should still work though.
Image

User avatar
eleazar
Design & Graphics Lead Emeritus
Posts: 3858
Joined: Sat Sep 23, 2006 7:09 pm
Location: USA — midwest

Re: Xenological Hybridization v4747

#4 Post by eleazar » Wed Mar 28, 2012 2:01 pm

Oops, you're right, my edits missed part of Xeno Genetics. Thanks.

Fixed revision 4757

User avatar
Darkspire
Space Floater
Posts: 27
Joined: Thu Nov 25, 2010 11:00 am
Location: My own private hell

Re: Xenological Hybridization v4747

#5 Post by Darkspire » Wed Mar 28, 2012 7:57 pm

unjashfan wrote:Oops - I think I got Xen Genetics and Xen Hybridization mixed up. Anyway, here's a screenshot of the problem and the save file.
test.zip
EDIT: Screenshot won't link as I would like to. Should still work though.
Image
Dude your link to the image should be an 18+ ... Those were not the big round planets I thought Id see :lol:

Darkspire

User avatar
eleazar
Design & Graphics Lead Emeritus
Posts: 3858
Joined: Sat Sep 23, 2006 7:09 pm
Location: USA — midwest

Re: Xenological Hybridization v4747

#6 Post by eleazar » Wed Mar 28, 2012 8:57 pm

There are a lot of less scummy options for hosting pictures, when you can't attach to the forum.

I don't know if my privileges are special, but i can attach in this post.

unjashfan
Creative Contributor
Posts: 175
Joined: Fri Dec 30, 2011 8:08 am

Re: Xenological Hybridization v4747

#7 Post by unjashfan » Wed Mar 28, 2012 10:11 pm

Dude your link to the image should be an 18+ ... Those were not the big round planets I thought Id see :lol:
Sorry about that. I figured we are mature enough to ignore the ads. I try to find hosts that do not require making an account since I don't upload pics often and I've also used that site before without this problem (in my post about rogue planets).

User avatar
Darkspire
Space Floater
Posts: 27
Joined: Thu Nov 25, 2010 11:00 am
Location: My own private hell

Re: Xenological Hybridization v4747

#8 Post by Darkspire » Wed Mar 28, 2012 11:09 pm

unjashfan wrote:
Dude your link to the image should be an 18+ ... Those were not the big round planets I thought Id see :lol:
Sorry about that. I figured we are mature enough to ignore the ads. I try to find hosts that do not require making an account since I don't upload pics often and I've also used that site before without this problem (in my post about rogue planets).
Oh its not a problem, just wasnt expecting it when I scrolled down, best laugh Ive had all day, have you tried Photobucket? Its so much easier to paste an image into your post using that, just copy the link and put the img brackets round it

Darkspire

unjashfan
Creative Contributor
Posts: 175
Joined: Fri Dec 30, 2011 8:08 am

Re: Xenological Hybridization v4747

#9 Post by unjashfan » Thu Mar 29, 2012 10:43 pm

I'll give photobucket a try next time. Thanks!

unjashfan
Creative Contributor
Posts: 175
Joined: Fri Dec 30, 2011 8:08 am

Re: Xenological Hybridization v4747

#10 Post by unjashfan » Fri Mar 30, 2012 7:09 pm

OK this time it's really about Xen Hybridization. Xen genetics doesn't seem to be active once this tech is active, but symbiotic biology still works. In the save file, Rimmer III is a small poor planet with a max population of 9 (scylior), but Tenebra I is adequate and has a max population of 8.5 (these systems are right under the capital). Other adequates seem to have lost the Xen genetics bonus.
test.zip
(162.53 KiB) Downloaded 13 times

User avatar
eleazar
Design & Graphics Lead Emeritus
Posts: 3858
Joined: Sat Sep 23, 2006 7:09 pm
Location: USA — midwest

Re: Xenological Hybridization v4747

#11 Post by eleazar » Fri Mar 30, 2012 7:37 pm

Again you've spotted my goofs. Looks like i forgot where i was in updating the effects.

I gave all those bio-population techs a check and spotted several other errors.

Revision 4768.
"fixed several bio-population techs not working as intended."

Post Reply