Page 1 of 1

v0.4.8 Ship Designs cannot be created

Posted: Thu Nov 28, 2019 2:31 pm
by Sheldar
I am suddenly unable to select the "Update Finished Design" button in the Ship Design window. It says it is an "Incomplete Ship Design" even when I use only valid components. I was able to do this earlier in my game session but not now.

Things I have tried:
1) save and reload: no change in behavior
2) close and reopen application: no change in behavior
3) reboot PC: no change in behavior
4) load an earlier save from the same game session: not able to design a ship
5) Start new game with "Single Player": not able to design a ship
6) Start new game with "Quick Start": not able to design a ship
7) Rename the application and pull a new copy of it from the installer, reload game from attempt 1: not able to design a ship

I have been using v0.4.8 (build 2018-08-23.26f16b0) on a Mac running 10.13.6 (I recently updated to this version of Mac OS but I was able to design ships earlier in this same game.)

Based on the symptoms I am thinking that I somehow managed to corrupt some files the Free Orion Application bundle uses that are outside the application bundle itself (maybe the same place the save games are stored.)

Based on this I tried removing the folder at: /Users/<username>/Library/Saved Application State/org.freeorion.FreeOrion.savedState

Once I did this and started the application again twice (it crashed the first time after loading, designing and going to the production window) I am able to add designs again. (solves the problem.)

I am not sure if I need a bug report on this or whether I just got my system in a weird state.

Re: v0.4.8 Ship Designs cannot be created

Posted: Thu Nov 28, 2019 5:55 pm
by Geoff the Medio
If you can find a way to reproduce the broken state, that would be a useful bug report. Otherwise, probably not.

Re: v0.4.8 Ship Designs cannot be created

Posted: Fri Nov 29, 2019 12:52 am
by Sheldar
I cannot recreate it. I put the original saved state back and the problem is still gone. Mark it up to a weird glitch.

Re: v0.4.8 Ship Designs cannot be created

Posted: Thu Dec 05, 2019 12:10 am
by Sheldar
I figured out what happened. When I select the "Saved" tab the right button changes to "Add Saved Design". If I change the tab to anything but "Finished" it stays "Add Saved Design". If I go to "Finished" it becomes "Add Finished Design" then when I change to any tab but "Saved" it stays "Add Finished Design".

I think this got crossed with the design already having been created. This resulted in the "Add Finished Design" being grayed out. I assume I moved to the "Saved" tab and then to the Hulls to create it from scratch. Since I was last on "Saved" the right button stays "Add Saved Design" and thus the design never goes into the list of ships that can be built.

I am not sure if this classifies as a bug, but at the very least it might be good to choose either "Add Finished Design" or "Add Saved Design" as the default for each of the tabs. Rather than keeping the one from the "Design" or "Saved" tab whichever is chosen last.