build 5396 OSX 10.8.2 Compile problem - Undefined symbols

Questions, problems and discussion about compiling FreeOrion.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
Computer.Pers
Space Floater
Posts: 39
Joined: Wed Nov 07, 2012 7:14 am

build 5396 OSX 10.8.2 Compile problem - Undefined symbols

#1 Post by Computer.Pers » Sat Nov 10, 2012 6:31 pm

Hi!

I'm trying to build svn version on my mac.
Xcode 4.5.2

Latest FreeOrionSDK for OSX

i get error messages:

Code: Select all

Undefined symbols for architecture i386:
  "parse::detail::effect_parser_3()", referenced from:
      parse::effect_parser()      in EffectParser.o
  "parse::detail::effect_parser_4()", referenced from:
      parse::effect_parser()      in EffectParser.o
ld: symbol(s) not found for architecture i386
collect2: ld returned 1 exit status
EffectParser.cpp i've added, but this doesn't helps me...
Attachments
Снимок экрана 2012-11-10 в 22.27.55.png
Снимок экрана 2012-11-10 в 22.27.55.png (124.35 KiB) Viewed 576 times

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12499
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: build 5396 OSX 10.8.2 Compile problem - Undefined symbol

#2 Post by Geoff the Medio » Sat Nov 10, 2012 6:51 pm

Did you update while XCode was open? It might have blocked the SVN client from updating the project file to include the files for EffectParser3 and 4...

Computer.Pers
Space Floater
Posts: 39
Joined: Wed Nov 07, 2012 7:14 am

Re: build 5396 OSX 10.8.2 Compile problem - Undefined symbol

#3 Post by Computer.Pers » Sat Nov 10, 2012 7:15 pm

Geoff the Medio wrote:Did you update while XCode was open? It might have blocked the SVN client from updating the project file to include the files for EffectParser3 and 4...
Yes i was tryed different ways and always Xcode was opened. I've closed it re-downloaded project.
Now compiling, will see helps this or not. Last time there wasn't such files in project, now they're there.

Computer.Pers
Space Floater
Posts: 39
Joined: Wed Nov 07, 2012 7:14 am

Re: build 5396 OSX 10.8.2 Compile problem - Undefined symbol

#4 Post by Computer.Pers » Sat Nov 10, 2012 7:34 pm

Geoff the Medio wrote:Did you update while XCode was open? It might have blocked the SVN client from updating the project file to include the files for EffectParser3 and 4...
Thank you, this helpes me.

Post Reply