SVN Updating Trouble [FYI]

Questions, problems and discussion about compiling FreeOrion.

Moderators: Oberlus, Oberlus

Post Reply
User avatar
Space Floater
Posts: 31
Joined: Fri Apr 29, 2011 3:58 pm
Location: UK

SVN Updating Trouble [FYI]

#1 Post by mrSpaceman » Sun Feb 05, 2012 3:52 pm

I tried to update the SDK using both SVN from the command line and Tortoise. Both had intermittent failures which manifested with the message:

[something like] Remote server has forcibly terminated the connection.

Sometimes the problem would be surmountable by restarting the update. I have [eventually] managed to update to the latest revision or FreeOrion and GG.

In a couple of cases, the restart didn't work, though if I switch to a different method of updating (ie., try Tortoise, or try the command line) then it would continue. One such case was when using the command line the process stopped on a file called "orbital?.png" or similar. Restarting the process in Tortoise worked and the asset was added as "orbital.png". The other case was when using Tortoise then process go stuck on a file which didn't seem suspect. Restarting from the command line did the trick.

My internet connection is pretty good. Also, I have a fairly good understanding of SVN. This just seemed a bit weird. I wonder if it was something on SourceForge's side of it, perhaps because I was updating for the first time.

I don't know the ins-and-outs of the FO project [yet] to say. GeoffTheMedio was saying on IRC that some assets with question marks in the filenames were added a while ago, though they've been cleaned up now. Perhaps the SDK is a bit old (out of step), though would that make a difference?

Hopefully now I have a full copy (figners crossed) there won't be any further problems.

Post Reply