Universe...

Questions, problems and discussion about compiling FreeOrion.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
emccormick
Space Krill
Posts: 3
Joined: Sat Sep 10, 2011 6:38 pm

Universe...

#1 Post by emccormick » Sat Sep 10, 2011 6:55 pm

I tried the binary install, but it gave me errors about missing files. So I decided to try the compile and seem to have it working, but it never generates a universe.

Windows XP, Visual C++ Express 2010

When I compiled, everything seemed to build, but when I ran freeorion.exe I got an error message that OpenAL32.dll is not a valid Windows program. have installed OpenAL recently for another program, so I have a recent version in my system32 directory. I renamed the one in the FreeOrion folder, then tried again.

This time, FreeOrion ran but there was an error about wrap_oal.dll. Since this is part of OpenAL, I renamed it also and tried again.

FreeOrion now runs, but it never generates a universe. I even went to bed and when I woke up there was no universe generated.

The OpenAL I have installed is file version 6.14.357.24.

Any suggestions on how to get it past this one?

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12474
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Universe...

#2 Post by Geoff the Medio » Sat Sep 10, 2011 7:19 pm

emccormick wrote:FreeOrion now runs, but it never generates a universe. I even went to bed and when I woke up there was no universe generated.
Locate freeoriond.log in C:\Documents and Settings\UserName\Application Data\FreeOrion and post its contents here. Hopefully there will be an error message indicating why the server crashed before it sent the first turn update. You might also try starting a game with 0 AIs, as starting them up can cause crashes as well.

emccormick
Space Krill
Posts: 3
Joined: Sat Sep 10, 2011 6:38 pm

Re: Universe...

#3 Post by emccormick » Sun Sep 11, 2011 2:31 am

No errors were in the log. This is all that was there. I do not know if more was in there the time I let it sit all night, but I doubt it.

Code: Select all

2011-09-10 10:32:39,531 DEBUG Server : (ServerFSM) Idle
2011-09-10 10:32:39,531 DEBUG Server : FreeOrion server waiting for network events
2011-09-10 10:32:50,265 DEBUG Server : ServerNetworking::AcceptConnection : connected to new player
2011-09-10 10:32:50,265 DEBUG Server : (ServerFSM) Idle.HostSPGame
2011-09-10 10:32:50,265 DEBUG Server : PlayerConnection(@ 00EB6C98)::EstablishPlayer(1, Zot, 1)
2011-09-10 10:32:50,265 DEBUG Server : (ServerFSM) ~Idle
2011-09-10 10:32:50,265 DEBUG Server : (ServerFSM) WaitingForSPGameJoiners
2011-09-10 10:32:50,265 DEBUG Server : ServerApp::CleanupAIs() killing 0 AI clients.
2011-09-10 10:32:50,265 DEBUG Server : starting E:\Game\FreeOrion\freeorionca.exe
2011-09-10 10:32:50,281 DEBUG Server : done starting E:\Game\FreeOrion\freeorionca.exe
2011-09-10 10:32:50,281 DEBUG Server : starting E:\Game\FreeOrion\freeorionca.exe
2011-09-10 10:32:50,281 DEBUG Server : done starting E:\Game\FreeOrion\freeorionca.exe
2011-09-10 10:32:50,281 DEBUG Server : starting E:\Game\FreeOrion\freeorionca.exe
2011-09-10 10:32:50,281 DEBUG Server : done starting E:\Game\FreeOrion\freeorionca.exe
2011-09-10 10:32:50,281 DEBUG Server : (ServerFSM) WaitingForSPGameJoiners.CheckStartConditions
2011-09-10 10:33:25,562 DEBUG Server : ServerNetworking::DisconnectImpl : disconnecting player 1
2011-09-10 10:33:25,562 DEBUG Server : ServerFSM::HandleNonLobbyDisconnection : Lost connection to player #1, named "Zot"; server terminating.
2011-09-10 10:33:25,562 DEBUG Server : ServerFSM::HandleNonLobbyDisconnection : All human players disconnected; server terminating.
But when I made the game with 0 AIs, it did start. So does that mean I can only run this without computer players?

User avatar
eleazar
Design & Graphics Lead Emeritus
Posts: 3858
Joined: Sat Sep 23, 2006 7:09 pm
Location: USA — midwest

Re: Universe...

#4 Post by eleazar » Sun Sep 11, 2011 4:09 am

In the past month i had trouble running FreeOrion with more than 0 AIs until i updated Python.
IIRC i got stuck in a similar place.

emccormick
Space Krill
Posts: 3
Joined: Sat Sep 10, 2011 6:38 pm

Re: Universe...

#5 Post by emccormick » Sun Sep 11, 2011 9:53 am

I renamed the python27.dll so it would use the 2.7.2 out of the system folder, and that seems to have done it. Thanks much!

Post Reply