Great-Scott! So much progress! And a few questions

For topics that do not fit in another sub-forum.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
Greendogo
Space Krill
Posts: 3
Joined: Sat Aug 11, 2012 5:49 am

Great-Scott! So much progress! And a few questions

#1 Post by Greendogo » Sat Aug 11, 2012 5:56 am

It's been eons since I last checked up on FreeOrion and I looked in right after the release of 4.1. I've got to say, the feel of the game is fantastic and you guys are doing a superb job!

I'd like to know if colony and outpost ships are capable of making colonies and outposts yet, because I didn't seem to be able to make either anywhere.
Are you planning to make the menus/windows more manageable? I found a few menus to be a little in the way, even at a very high screen resolution.
Are you eventually going to make the research window more maneuverable, such as putting a click and drag functionality to traverse it, and perhaps improve its ability to reorganize itself after changing the filters?

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12485
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Great-Scott! So much progress! And a few questions

#2 Post by Geoff the Medio » Sat Aug 11, 2012 6:10 am

Greendogo wrote:I'd like to know if colony and outpost ships are capable of making colonies and outposts yet, because I didn't seem to be able to make either anywhere.
They are working fine as far as I can tell. Perhaps you don't know how to use them? Note that the colony or outpost ship must be in the same system and selected in the fleets window before it can be used to colonize or create an outpost. The planet's type must also be suitable, with colony ships generally having more restrictions than outposts ships.
Are you eventually going to make the research window more maneuverable, such as putting a click and drag functionality to traverse it...
This is already implemented.

Greendogo
Space Krill
Posts: 3
Joined: Sat Aug 11, 2012 5:49 am

Re: Great-Scott! So much progress! And a few questions

#3 Post by Greendogo » Sat Aug 11, 2012 6:30 am

Regarding the Research window, I guess I just didn't try it.

Regarding the colony ships, well I just started a new game and they worked, but I played a game yesterday where none of the colony or outpost ships worked. I still played that game for 3 hours, but I just assumed the ships didn't work yet.

Anyway, I'm glad that all works!

Post Reply